Issue
My local backup is using 'Veeam Endpoint for Windows' and an external USB Hard Drive which were working fine until after a Windows Update. It took a while before I worked out the link between the update and Veeam.
I would get errors like these shown below.
Error: Full backup file merge failed
26/01/2024 18:09:41 :: Full backup file merge failed Error: Agent: Failed to process method {Transform.Patch}: The media is write protected.
Error: Asynchronous read operation failed
26012024 215538 Error The device is not ready. Asynchronous read operation failed Failed to upload disk. Agent failed to process method {DataTransfer.SyncDisk}. Exception from server The device is not ready. Unable to retrieve next block transmission command. Number of already processed blocks [86184]. Failed to download disk 'xxxxxxxx-xxxx-xxxx-xxxx-xxxxxxxxxxxx'
Cause
After a Windows Update, there was something wrong with the mount point for the 'Recovery Partition' because the update had corrupted the partition somehow. Because of this corruption, Veeam cannot correctly mount the 'Recovery Partition' so the backup fails.
Solution
Mount and Unmount the 'Recovery Partition' (Add and Remove a drive letter)
- What this seems to do is fix the mount point for the partition and this allows Veeam to complete it's backup.
- When I added a drive letter I found there were no files on my 'Recovery Partition'.
- There are many different ways you can do this but here are a few:
- diskpart (via cmd)
- Powershell
- Install a partition manager into Windows.
- Boot from a partition manager, assign a drive letter, load Windows, boot from the partition manager again and remove the drive letter.
The backup will show a success message as follows:
Research
- Error: The device is not ready. Asynchronous read operation failed Failed to upload disk | Veeam Community
- I ran into this error too. Somehow recovery vol had it's mount point removed. Not sure why. The solution was just to mount it somewhere (mountvol c:\mount "\\?\Volume{GUID}\"), and then dismount with mountvol /D. After this volume no longer shows as having RAW FS, and Veeam Agent is able to take backups again.
- Microsoft admits that latest Windows 10 update has a peculiar error - and it’s working to fix it ASAP | TechRadar - Playing the waiting game...
- The New Microsoft Update didn't work so I followed their instructions on how to resize my recovery partition | Microsoft Commuity
- KB5028997: Instructions to manually resize your partition to install the WinRE update - Microsoft Support